re = /(?<!@\{)(?<=\{).*?(?=\})/
str = ' 1 {eww} r23r23{fetwe}
2 #{d2dded}
3 @{d2dded}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end