$re = '`^(?:\D+)?(?:(?:[5-6](?:(?:\.|\,)[1-9])?)|(?:[6-7](?:(?:\.|\,)0)?))(?:(?:\s?pol)|"|\'\'|\x60|\'|´|”)?(?:.*)`s';
$str = '4.5 polegadas (~ 64,3% relação tela-corpo)
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5"-6" polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
^(?:(6(?:\\.|\\,)0)|(5(?:\\.|\\,)[1-9]))(.*)
\\s?(?:(?:\\d+)(?:\\.|\\,)?(?:\\d+)?)(?:"|\'\'|\\x60|\'|´|”)
(?:(5(?:\\.|\\,)0)|(4(?:\\.|\\,)[1-9]))(.*)
(4(?:\\.|\\,)[1-9])(.*) => 4-5
(5(?:\\.|\\,)[0]))(.*) => 4-5';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);