// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)^(?:\D+)?(?:(?:[5-6](?:(?:\.|\,)[1-9])?)|(?:[6-7](?:(?:\.|\,)0)?))(?:(?:\s?pol)|"|''|\x60|'|´|”)?(?:.*)"#).unwrap();
let string = "4.5 polegadas (~ 64,3% relação tela-corpo)
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5\"-6\" polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
^(?:(6(?:\\.|\\,)0)|(5(?:\\.|\\,)[1-9]))(.*)
\\s?(?:(?:\\d+)(?:\\.|\\,)?(?:\\d+)?)(?:\"|''|\\x60|'|´|”)
(?:(5(?:\\.|\\,)0)|(4(?:\\.|\\,)[1-9]))(.*)
(4(?:\\.|\\,)[1-9])(.*) => 4-5
(5(?:\\.|\\,)[0]))(.*) => 4-5";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}