import re
regex = re.compile(r"(?:15620450000|VS|00)\d{8}", flags=re.MULTILINE)
test_str = ("1562045000012345678\n"
"VS12345678\n"
"0012345678\n"
"12345678")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")