re = /(?:15620450000|VS|00)\d{8}/m
str = '1562045000012345678
VS12345678
0012345678
12345678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end