package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([ -~]{1,})$`)
var str = `//#define STR "QWERTYUIOPASDFGHJKLZXCVBNM"
//#define STR "qwertyuiopasdfghjklzxcvbnm123456789"
//#define STR "\`~!@#$%^&*()-_+={[}]|\\;:i\"'<,>.?/"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}