re = /^([ -~]{1,})$/m
str = '//#define STR "QWERTYUIOPASDFGHJKLZXCVBNM"
//#define STR "qwertyuiopasdfghjklzxcvbnm123456789"
//#define STR "`~!@#$%^&*()-_+={[}]|\\\\;:i\\"\'<,>.?/"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end