using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#\s?renovate: datasource=(?<datasource>.*?)\n\s+.*?:(?<registryUrl>.*)\/(?<depName>.*):(?<currentValue>.*)";
string input = @" # renovate: datasource=docker
image: registry.gitlab.com/sylva-projects/sylva-elements/container-images/kube-job:v1.0.10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}