package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#\s?renovate: datasource=(?<datasource>.*?)\n\s+.*?:(?<registryUrl>.*)\/(?<depName>.*):(?<currentValue>.*)`)
var str = ` # renovate: datasource=docker
image: registry.gitlab.com/sylva-projects/sylva-elements/container-images/kube-job:v1.0.10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}