$re = '/#\s?renovate: datasource=(?<datasource>.*?)\n\s+.*?:(?<registryUrl>.*)\/(?<depName>.*):(?<currentValue>.*)/m';
$str = ' # renovate: datasource=docker
image: registry.gitlab.com/sylva-projects/sylva-elements/container-images/kube-job:v1.0.10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);