$re = '/^([a-zA-Z0-9]*)_(a_)?.*(_(\d+))?\.\w+$/';
$str = 'RGF0027_a_Test string_987.test_004.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);