// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([a-zA-Z0-9]*)_(a_)?.*(_(\d+))?\.\w+$").unwrap();
let string = "RGF0027_a_Test string_987.test_004.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}