re = /^([a-zA-Z0-9]*)_(a_)?.*(_(\d+))?\.\w+$/
str = 'RGF0027_a_Test string_987.test_004.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end