package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\W_]+`)
var str = `Úm Titulo`
var substitution = "-"
fmt.Println(re.ReplaceAllString(str, substitution))
}