use strict;
my $str = 'Úm Titulo';
my $regex = qr/[\W_]+/up;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";