import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\()\\d{1,}\\.{0,}\\/{0,}-{0,}\\d{0,}(?=\\))";
final String string = "Account Name (123.54)\n"
+ "Account Name (123)\n"
+ "Account Name (123/54)\n"
+ "Account Name (123-54)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}