$re = '/(?<=\()\d{1,}\.{0,}\/{0,}-{0,}\d{0,}(?=\))/';
$str = 'Account Name (123.54)
Account Name (123)
Account Name (123/54)
Account Name (123-54)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);