import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\)>\\u001E01\\u001D[0-9]{2}[0-9A-Z ]{6}\\u001D[0-9]{3}\\u001D[0-9]{3}\\u001D.+";
final String string = "[)>01961A2B3C1241231Z00ETC\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}