re = /\[\)>\u001E01\u001D[0-9]{2}[0-9A-Z ]{6}\u001D[0-9]{3}\u001D[0-9]{3}\u001D.+/m
str = '[)>01961A2B3C1241231Z00ETC
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end