$re = '/CN\=(?<LastName>[^\\\\]*)\\\\,\s(?<FirstName>[^,]*),/';
$str = 'CN=LastName\\, FirstName,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);