re = /CN\=(?<LastName>[^\\]*)\\,\s(?<FirstName>[^,]*),/
str = 'CN=LastName\\, FirstName,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end