const regex = new RegExp('^[1-31].[1-12]', 'gm')
const str = `13.11.1986
01.01.1999
31.12.2020
15.06.2000
01.01.1920
############### Not valid ###########################
31.12.1919
12.13.1985
1.1.2005
1.5.86
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}