use strict;
my $str = '13.11.1986
01.01.1999
31.12.2020
15.06.2000
01.01.1920
############### Not valid ###########################
31.12.1919
12.13.1985
1.1.2005
1.5.86
';
my $regex = qr/^[1-31].[1-12]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}