#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*((MP server version)|(Server version)):\s*(?P<version>.*?)(?=\s|$)"
Local $sString = "2022/11/13, 11:53:11 2022-11-13 19:53:11:377 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1.872dbb3" & @CRLF & _
"" & @CRLF & _
"2022/12/04, 13:23:48 2022-12-04 21:23:48:085 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1.7085c62" & @CRLF & _
"" & @CRLF & _
"2022/12/03, 20:58:26 2022-12-04 04:58:26:336 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1" & @CRLF & _
"" & @CRLF & _
"2022/12/03, 20:58:26 2022-12-04 04:58:26:336 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1.alpha1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")