using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*((MP server version)|(Server version)):\s*(?P<version>.*?)(?=\s|$)";
string input = @"2022/11/13, 11:53:11 2022-11-13 19:53:11:377 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1.872dbb3
2022/12/04, 13:23:48 2022-12-04 21:23:48:085 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1.7085c62
2022/12/03, 20:58:26 2022-12-04 04:58:26:336 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1
2022/12/03, 20:58:26 2022-12-04 04:58:26:336 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1.alpha1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}