# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*((MP server version)|(Server version)):\s*(?P<version>.*?)(?=\s|$)"
test_str = ("2022/11/13, 11:53:11 2022-11-13 19:53:11:377 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1.872dbb3\n\n"
"2022/12/04, 13:23:48 2022-12-04 21:23:48:085 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1.7085c62\n\n"
"2022/12/03, 20:58:26 2022-12-04 04:58:26:336 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1\n\n"
"2022/12/03, 20:58:26 2022-12-04 04:58:26:336 | Antistasi | Info | File: A3A_fnc_initServer | Server version: 2.6.1.alpha1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.