# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/.*//gm;t' <<< "Баланс: -19443 / Холд: 923310"