package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|\s)([-+]?\d*\.\d+|\d+)`)
var str = `1 0.6271 bacs T123 Biologically Active Substance`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}