$re = '/(^|\s)([-+]?\d*\.\d+|\d+)/m';
$str = '1 0.6271 bacs T123 Biologically Active Substance';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);