re = /(^|\s)([-+]?\d*\.\d+|\d+)/m
str = '1 0.6271 bacs T123 Biologically Active Substance'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end