using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=[A-Z])[^A](?=[A-Z])[^J](?!=[A-Z])[^K]\b";
string input = @"HEL lloosd PSL ipsum JWS pos PPSS AKJ AJK";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}