re = /\b(?=[A-Z])[^A](?=[A-Z])[^J](?!=[A-Z])[^K]\b/
str = 'HEL lloosd PSL ipsum JWS pos PPSS AKJ AJK'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end