$re = '/\b(?=[A-Z])[^A](?=[A-Z])[^J](?!=[A-Z])[^K]\b/';
$str = 'HEL lloosd PSL ipsum JWS pos PPSS AKJ AJK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);