# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9]{4}.G[0-9]{2}(?: [0-9]{4}.G[0-9]{2})* |( )(?=Jednostki))/\0\n/gm;t' <<< "Dane osobowe po zmianie (dopisane): Surname1 Name1 (RYSZARD, EUGENIA) Zam. 99-100 Muczyn (Geod) 6A, Płeć: K, PESEL: 99945104321 Jednostki Rejestrowe osoby (w gminie): 0001.G16 0002.G56 Surname2 Name2 (ANDRZEJ, AGNIESZKA) Zam. 99-100 Muczyn (Geod) 4A, Płeć: K Jednostki Rejestrowe osoby (w gminie): 0001.G16 0001.G07 0001.G43 Surname1 Name1 Name2 (ANDRZEJ, AGNIESZKA) Zam. 99-100 MUCZYN (Geod) 4A, Płeć: M Jednostki Rejestrowe osoby (w gminie): 0001.G16"