package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[+|-]+\d{2}:\d{2}`)
var str = `UTC +01:00
UTC +01:30
UTC -01:00
UTC -03:30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}