// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[+|-]+\d{2}:\d{2}").unwrap();
let string = "UTC +01:00
UTC +01:30
UTC -01:00
UTC -03:30";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}