$re = '/[+|-]+\d{2}:\d{2}/m';
$str = 'UTC +01:00
UTC +01:30
UTC -01:00
UTC -03:30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);