using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"# Input\n(# (?:.*?))# Output";
string input = @"# Input
# data/raw/file1
# data/raw/file2
# Output
# data/interim/file1
# data/interim/file2";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}