// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)# Input\n(# (?:.*?))# Output").unwrap();
let string = "# Input
# data/raw/file1
# data/raw/file2
# Output
# data/interim/file1
# data/interim/file2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}