re = /# Input\n(# (?:.*?))# Output/
str = '# Input
# data/raw/file1
# data/raw/file2
# Output
# data/interim/file1
# data/interim/file2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end