# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-z]{1})\s?['‘’]([0-9]{2})/$1 ’$2/gm;t' <<< "John Caster’14
Sally Mellan'98
Jack Frost '56"