import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-z]{1})\\s?['‘’]([0-9]{2})";
final String string = "John Caster’14\n"
+ "Sally Mellan'98\n"
+ "Jack Frost '56";
final String subst = "$1 ’$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}