$re = '/([A-z]{1})\s?[\'‘’]([0-9]{2})/m';
$str = 'John Caster’14
Sally Mellan\'98
Jack Frost \'56';
$subst = "$1 ’$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;