using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!#\| label:).+(*SKIP)(*F)|_";
string substitution = @"-";
string input = @"#| label: my_chunk_label
my_function_name <- function(x)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}