use strict;
my $str = '#| label: my_chunk_label
my_function_name <- function(x)';
my $regex = qr/^(?!#\| label:).+(*SKIP)(*F)|_/mp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";