const regex = /^(?!#\| label:).+(*SKIP)(*F)|_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!#\\| label:).+(*SKIP)(*F)|_', 'gm')
const str = `#| label: my_chunk_label
my_function_name <- function(x)`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);