const regex = /^[\d_]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\d_]+', 'gm')
const str = `0001_Smoke_B_B
0002_Smoke_B_B
0012_Smoke_B_B
MA103
MA104
00_00MA105`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}