using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"src=\""([^""]+)\""";
string input = @"<img class=""my-page__icon-img"" src=""https://site.com/static/icons/vector/some.svg"" alt=""Img"" width=""40"" height=""40"">
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}