re = /src=\"([^"]+)\"/
str = '<img class="my-page__icon-img" src="https://site.com/static/icons/vector/some.svg" alt="Img" width="40" height="40">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end