package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`src=\"([^"]+)\"`)
var str = `<img class="my-page__icon-img" src="https://site.com/static/icons/vector/some.svg" alt="Img" width="40" height="40">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}